PDA

View Full Version : Canon 350D (XT) with a Mac


HillsCass
07-16-2006, 05:25 AM
Hi everyone,

I have a plea for help if anyone out there has this particular combination...

Dh just bought me my first Mac, a dual processor Mini and I'm having lots of fun getting everything onto it. I have hit my first major snag in the Canon software. I've installed it as per instructions, and I've downloaded a couple of updates from the Canon site.

Their troubleshooting is particularly silly as when I try to ask for help with my problem they ask the basic questions, ie is the camera connected to the computer etc, but then they ask what operating system am I using and give me 4 windows choices, no mac. Rofl....

I have successfully loaded the software and updates, but I still cannot get the software (Particularly the camera window) to recognise the camera. When I launch it it locks for a minute and then just dies. For what it's worth, I'm using Tiger 10.4.7

Anyone got any ideas on my problem? I'm getting to the totally frustrated stage! :)

Thanks in advance....

RobynV
07-16-2006, 09:50 AM
I have an dual processor iMac and the Rebel XT, but I'm no help I'm afraid. I have never even installed the Canon software. I used Elements originally and just upgraded to PS CS2. It's not native for the Mac yet, but I'm finding it's still pretty fast. I can't wait till CS3 comes out for the Mac. I'll be smokin'!! LOL

You can download free trials of both from Adobe.com. Totally woroth it to see if it will works on your machine. I tried out CS2 first to make sure it worked well on my Mac.

Good luck.

lunafaerie
07-16-2006, 01:51 PM
I wish I could help Cass, but my digital camera is an Olympus. I'm sure Cannon and Mac are compatible, maybe contact Mac support, they might be more help.

Mac is supposed to be plug and perform for most everything, when you plug it in do you see a "drive" pop up on your desktop? Try opening iPhoto and see if you can import the photos or if it reads the camera.

I'm afraid that's all the help I can think of.

caridura
07-16-2006, 03:39 PM
I'm not much help either since I never installed the Canon software. I just plug my XT into my iBook and upload my photos that way and then I use PSE to do any editing.

Have you tried a Google search? It might bring up some Mac forums where you can find an answer.

HillsCass
07-17-2006, 01:39 AM
Thanks for the answers anyway....

We found an interesting couple of threads at an Apple support forum, apparently it DOES have to do with the version of Tiger I"m running and a USB Connectivity issue... Apple and Canon claim to be working on a fix, but meanwhile everyone is just hanging on it....

I do use CS2 already, but I just miss my Canon Image browser - it's such a big step down from Picasa to iPhoto... not really got my head around the organisation thing yet....

Thanks again everyone! :)